package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.{1,22})(?:,|$)`)
var str = `test1,test2,test3,test4,test5
test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6
`
var substitution = "$1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}