$re = '/(.{1,22})(?:,|$)/m';
$str = 'test1,test2,test3,test4,test5
test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6
';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;