# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.{1,22})(?:,|$)"
test_str = ("test1,test2,test3,test4,test5\n"
"test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6\n")
subst = "$1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.