const regex = /(.{1,22})(?:,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{1,22})(?:,|$)', 'gm')
const str = `test1,test2,test3,test4,test5
test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6
`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);