use strict;
my $str = 'test1,test2,test3,test4,test5
test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6
';
my $regex = qr/(.{1,22})(?:,|$)/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";