import Foundation
let pattern = #"(.{1,22})(?:,|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test1,test2,test3,test4,test5
test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)