// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.{1,22})(?:,|$)").unwrap();
let string = "test1,test2,test3,test4,test5
test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6
";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}