re = /(.{1,22})(?:,|$)/m
str = 'test1,test2,test3,test4,test5
test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6
'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result