# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"[^"]+"(*SKIP)(*FAIL)|\h+/\n/gm;t' <<< "+word1 -word2 -\"word word\""