const regex = /"[^"]+"(*SKIP)(*FAIL)|\h+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]+"(*SKIP)(*FAIL)|\\h+', 'gm')
const str = `+word1 -word2 -"word word"`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);