import re
regex = re.compile(r"\"[^\"]+\"(*SKIP)(*FAIL)|\h+", flags=re.MULTILINE)
test_str = "+word1 -word2 -\"word word\""
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)