using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]+""(*SKIP)(*FAIL)|\h+";
string substitution = @"\n";
string input = @"+word1 -word2 -""word word""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}