$re = '/"[^"]+"(*SKIP)(*FAIL)|\h+/m';
$str = '+word1 -word2 -"word word"';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;