package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"]+"(*SKIP)(*FAIL)|\h+`)
var str = `+word1 -word2 -"word word"`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}