const regex = /<\/?[\w\s\/"=]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?[\\w\\s\\\/"=]*>', 'gm')
const str = `<h2 class="offscreen">Learn Web Development</h2>
<h1>Regular Expressions</h1>
<p>"All parts of MDN (documents and the website itself) are created by an open community."</p>
<a href="/nl/docs/MDN/Getting_started">Getting started</a>
<bed el = ekf"eee>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}