// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<\/?[\w\s\/"=]*>"#).unwrap();
let string = "<h2 class=\"offscreen\">Learn Web Development</h2>
<h1>Regular Expressions</h1>
<p>\"All parts of MDN (documents and the website itself) are created by an open community.\"</p>
<a href=\"/nl/docs/MDN/Getting_started\">Getting started</a>
<bed el = ekf\"eee>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}