import Foundation
let pattern = #"<\/?[\w\s\/"=]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<h2 class="offscreen">Learn Web Development</h2>
<h1>Regular Expressions</h1>
<p>"All parts of MDN (documents and the website itself) are created by an open community."</p>
<a href="/nl/docs/MDN/Getting_started">Getting started</a>
<bed el = ekf"eee>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)