# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\/?[\w\s\/\"=]*>"
test_str = ("<h2 class=\"offscreen\">Learn Web Development</h2>\n"
"<h1>Regular Expressions</h1>\n"
"<p>\"All parts of MDN (documents and the website itself) are created by an open community.\"</p>\n"
"<a href=\"/nl/docs/MDN/Getting_started\">Getting started</a>\n"
"<bed el = ekf\"eee>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.