# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Get-Content\s+(['"]?)C:\\bulk\\).*?(\.txt\2)/${1}BBB$3/gm;t' <<< "$line = ''
Get-Content C:\bulk\XXX.txt |
Select-String -Pattern 'TEMP' |
ForEach-Object {
#blah blah
}"