use strict;
my $str = '$line = \'\'
Get-Content C:\\bulk\\XXX.txt |
Select-String -Pattern \'TEMP\' |
ForEach-Object {
#blah blah
}';
my $regex = qr/(Get-Content\s+(['"]?)C:\\bulk\\).*?(\.txt\2)/mp;
my $subst = '${1}BBB$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";