$re = '/(Get-Content\s+([\'"]?)C:\\\\bulk\\\\).*?(\.txt\2)/m';
$str = '$line = \'\'
Get-Content C:\\bulk\\XXX.txt |
Select-String -Pattern \'TEMP\' |
ForEach-Object {
#blah blah
}';
$subst = "${1}BBB$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;