using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Get-Content\s+(['""]?)C:\\bulk\\).*?(\.txt\2)";
string substitution = @"${1}BBB$3";
string input = @"$line = ''
Get-Content C:\bulk\XXX.txt |
Select-String -Pattern 'TEMP' |
ForEach-Object {
#blah blah
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}