import Foundation
let pattern = #"(Get-Content\s+(['"]?)C:\\bulk\\).*?(\.txt\2)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
$line = ''
Get-Content C:\bulk\XXX.txt |
Select-String -Pattern 'TEMP' |
ForEach-Object {
#blah blah
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1}BBB$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)