const regex = /(Get-Content\s+(['"]?)C:\\bulk\\).*?(\.txt\2)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Get-Content\\s+([\'"]?)C:\\\\bulk\\\\).*?(\\.txt\\2)', 'gm')
const str = `\$line = ''
Get-Content C:\\bulk\\XXX.txt |
Select-String -Pattern 'TEMP' |
ForEach-Object {
#blah blah
}`;
const subst = `${1}BBB$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);