import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-1]+)(?:([+|\\-|\\/|*])([0-1]+))*$";
final String string = "1010101+101\n"
+ "10101*111\n"
+ "00011/0\n"
+ "10-010000\n"
+ "11\n"
+ "100101\n"
+ "1010101+-101\n"
+ "1992-1231+\n"
+ "1009/3100\n"
+ "120120120\n"
+ "0001+\n"
+ "10-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}