const regex = /^([0-1]+)(?:([+|\-|\/|*])([0-1]+))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-1]+)(?:([+|\\-|\\\/|*])([0-1]+))*$', 'gm')
const str = `1010101+101
10101*111
00011/0
10-010000
11
100101
1010101+-101
1992-1231+
1009/3100
120120120
0001+
10-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}