import re
regex = re.compile(r"^([0-1]+)(?:([+|\-|\/|*])([0-1]+))*$", flags=re.MULTILINE)
test_str = ("1010101+101\n"
"10101*111\n"
"00011/0\n"
"10-010000\n"
"11\n"
"100101\n"
"1010101+-101\n"
"1992-1231+\n"
"1009/3100\n"
"120120120\n"
"0001+\n"
"10-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")