use strict;
my $str = '1010101+101
10101*111
00011/0
10-010000
11
100101
1010101+-101
1992-1231+
1009/3100
120120120
0001+
10-';
my $regex = qr/^([0-1]+)(?:([+|\-|\/|*])([0-1]+))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}