# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^a]*)a(.*)$/$1*a*$2/gm;t' <<< "[[12][abad][32][@adb.]
"