// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^a]*)a(.*)$").unwrap();
let string = "[[12][abad][32][@adb.]
";
let substitution = "$1*a*$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}