const regex = /^([^a]*)a(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^a]*)a(.*)$', 'gm')
const str = `[[12][abad][32][@adb.]
`;
const subst = `$1*a*$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);