package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^a]*)a(.*)$`)
var str = `[[12][abad][32][@adb.]
`
var substitution = "$1*a*$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}