$re = '/^([^a]*)a(.*)$/m';
$str = '[[12][abad][32][@adb.]
';
$subst = "$1*a*$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;