use strict;
my $str = '[[12][abad][32][@adb.]
';
my $regex = qr/^([^a]*)a(.*)$/mp;
my $subst = '$1*a*$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";