#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^a]*)a(.*)$"
Local $sString = "[[12][abad][32][@adb.]" & @CRLF & _
""
Local $sSubst = "$1*a*$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)