import Foundation
let pattern = #"^([^a]*)a(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[[12][abad][32][@adb.]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1*a*$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)