re = /^([^a]*)a(.*)$/m
str = '[[12][abad][32][@adb.]
'
subst = '$1*a*$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result