#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(attrs=){([^:{]+:*[^}]*)}"
Local $sString = "this.mk(attrs={keyCollection.key: 40}))" & @CRLF & _
"this.mk(attrs={keyCollection.key: 50, override.key: override.value})" & @CRLF & _
"this.mk(attrs={keyCollection.key: 60, " & @CRLF & _
" override.key: override.value})"
Local $sSubst = "$1[[$2]]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)