import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(attrs=)\\{([^:\\{]+:*[^\\}]*)\\}";
final String string = "this.mk(attrs={keyCollection.key: 40}))\n"
+ "this.mk(attrs={keyCollection.key: 50, override.key: override.value})\n"
+ "this.mk(attrs={keyCollection.key: 60, \n"
+ " override.key: override.value})";
final String subst = "$1[[$2]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}