using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(attrs=){([^:{]+:*[^}]*)}";
string substitution = @"$1[[$2]]";
string input = @"this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}