// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(attrs=){([^:{]+:*[^}]*)}").unwrap();
let string = "this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})";
let substitution = "$1[[$2]]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}