$re = '/(attrs=){([^:{]+:*[^}]*)}/m';
$str = 'this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})';
$subst = "$1[[$2]]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;