re = /(attrs=){([^:{]+:*[^}]*)}/m
str = 'this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})'
subst = '$1[[$2]]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result