const regex = /(attrs=){([^:{]+:*[^}]*)}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(attrs=){([^:{]+:*[^}]*)}', 'gm')
const str = `this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})`;
const subst = `$1[[$2]]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);