package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(attrs=){([^:{]+:*[^}]*)}`)
var str = `this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})`
var substitution = "$1[[$2]]"
fmt.Println(re.ReplaceAllString(str, substitution))
}