import Foundation
let pattern = #"(attrs=){([^:{]+:*[^}]*)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1[[$2]]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)