# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?i)(?!administrator|root).+//gm;t' <<< "Administrator
aDmInIsTrAtOr
Root
root
jsmith
JSmith
Any_Text_Really
Any_meta_char_%$#!_and_12345"