import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i)(?!administrator|root).+";
final String string = "Administrator\n"
+ "aDmInIsTrAtOr\n"
+ "Root\n"
+ "root\n"
+ "jsmith\n"
+ "JSmith\n"
+ "Any_Text_Really\n"
+ "Any_meta_char_%$#!_and_12345";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}