# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?i)(?!administrator|root).+"
test_str = ("Administrator\n"
"aDmInIsTrAtOr\n"
"Root\n"
"root\n"
"jsmith\n"
"JSmith\n"
"Any_Text_Really\n"
"Any_meta_char_%$#!_and_12345")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.