use strict;
my $str = 'Administrator
aDmInIsTrAtOr
Root
root
jsmith
JSmith
Any_Text_Really
Any_meta_char_%$#!_and_12345';
my $regex = qr/^(?i)(?!administrator|root).+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";